tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу, которая
Написать программу, которая выводит на экран из введенной пользователем строки слово с заданным пользователем номером c++ ,
Adashok
2 26.08.2019 10:40
3
Ответы
кика20052
05.10.2020 20:48
#include <bits/stdc++.h>
using namespace std;
int main(){ string s; getline(cin, s); int n; cin >> n; int cur = 1, i; for(i = 0 ; i < s.size() ; i ++) { if(s[i] == ' ') cur++; if(cur >= n) break; } string ans = ""; if(n != 1) ++i; while(s[i] != ' ' && i < s.size()) { ans += s[i]; ++i; } cout << ans << "\n";}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
YulyaDremina
13.08.2021 12:34
Кредит в сумме S млн руб., выданный на n лет под i% годовых, подлежит погашению равными ежегодными выплатами в конце каждого года, включающими процентные платежи и сумму в погашение...
VERONIKA114561378
13.08.2021 12:40
На числовой прямой даны два отрезка: Р = [5, 15] и Q = [12, 18]. Выберите такой вариант отрезка А, что формула тождественно истинна, то есть принимает значение 1 при любом значении...
hoivamvrot
13.04.2021 12:25
Задание по информатике на Pascal. Файл содержит 10 произвольных трезначных чисел. Вывести в файл все четные числа, упорядочив их по убыванию....
Merlin131
13.04.2021 12:26
написать программу на Паскале тема: циклы...
NeekaFox
04.05.2020 09:08
5. Как называют совокупность свойств (признаков) объекта? 1) его описанием 3) его характеристикой 2) его параметрами 4) его особенностью...
Неоченьумноесущество
04.05.2020 09:09
Составьте скрипт для повторения действий 10 раз...
avaitekhovich
08.02.2021 18:39
Уйсунская диадема эссе 100 слов...
nadiasotochka
08.02.2021 18:39
9 1066 Choose the correct item. 1 Vincent Van Gogh, the famous Dutch painter,spent much/many of his life in France2 How many/few of the actors can actuallydance, sing and act...
igorzarubin2006
08.02.2021 18:39
3. Берілген сөздердің синонимдерін тауып, сөйлем құрайық: күннің көз жасы тыйылмады, қарасын көрсетпеу, жүрген жеріне шоп шықпау, отқа да, суғада түсу, баукеспе. ДАМ ВСЁ ПРАВД...
beliaeva201
08.02.2021 18:39
составить 1 предложение с 1 словом! Palet,plik,cărunt,mut,viţel....
Популярные вопросы
Подскажите проверочное слово к слову какой...
3
Длина класса 10 м,она на 1 м больше ширины.в классе 29 учеников и учитель.какая...
2
Не могу понять как решить. вычислить сумму корней квадратных первых n чисел...
3
Определите сколько раз встречается звук т в следующих скороговорках: 1) ткёт...
1
Втрапеции abcd угол a = 90° высота ce делит основание ad на два равных отрезка,...
3
Вставьте пропущенные слова-названиясогласных звуков: согласный звук состоит...
2
Отрезок ch - высота треугольника абс, в котором ас=4√3, сн=6. найдите сторону...
3
Кличка собаки которую подарили на день роджения малыш?...
3
Всвязи с чем обмен веществ у земноводных не может обеспечить организм высокой...
3
Как проверить в слове колибри букву о? буду...
2
using namespace std;
int main(){ string s; getline(cin, s); int n; cin >> n; int cur = 1, i; for(i = 0 ; i < s.size() ; i ++) { if(s[i] == ' ') cur++; if(cur >= n) break; } string ans = ""; if(n != 1) ++i; while(s[i] != ' ' && i < s.size()) { ans += s[i]; ++i; } cout << ans << "\n";}