Написать программу,которая выведет все числа кратные 3 в диапазоне от 26 до 87

buslabik1 buslabik1    1   23.07.2019 14:10    2

Ответы
muradveliyev muradveliyev  03.10.2020 11:38
//Pascal ABC.NET v3.1 сборка 1172

begin
range(26,87).Where(x -> x mod 3=0).Println(',');
end.
ПОКАЗАТЬ ОТВЕТЫ
adile1991 adile1991  03.10.2020 11:38
Решение №1 (через целочисленное деление)

var a: integer;
begin
  a:=26;
  repeat
    if a mod 3 =0 then write(a:3);
    a:=a+1;
  until a >87;
end.

Решение №2 (без целочисленного деления)
Заметим, что первое число в данном диапазоне кратное 3 равно 27. Тогда каждое следуещее число на 3 больше предыдущего:

var a: integer;
begin
  a:=27;
  repeat
    write(a:3);
    a:=a+3;
  until a >87;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика