Написать программу, которая выведет 4 первые четных числа(2,4,6,8) и написать программу которая находит сумму этих чисел.

elzamarg elzamarg    3   27.06.2019 15:10    6

Ответы
maksimgrig12 maksimgrig12  02.10.2020 13:12
У меня вот так вышло, хотя можно еще несколькими сделать эту задачу

int main()
{
int mass[10]; //оглашаем массив из 10 целых чисел(или сколько захотите сами)

//как заполнить массив решите сами

int temp[4];//массив который будет хранить 4 четных элемента
int flag=0;
int j=0;

for(int i=flag;i<10;++i)
{
if(mass[i]%2)temp[j]=mass[i];
flag=i;
++j;
}

int Sum=0;
for(int j=0;j<4;++j)
{Sum+=temp[j];
cout<<temp[j]<<"\n";
}
cout<<Sum;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика