Написать программу, которая вычисляет оптимальный вес пользователя,
сравнивает его с реальным и выдает рекомендацию о необходимости
поправиться или похудеть. Оптимальный вес вычисляется по формуле: рост (в
сантиметрах)-100. Рекомендуемый вид экрана во время работы программы
приведен ниже (данные, введенные пользователем, выделены полужирным
шрифтом).
Введите в одной строке через пробел
рост (см) и вес (кг) затем нажмите
-> 170 68
Вам надо поправиться на 2.00 кг.
(Язык программирования - паскаль)

Stasya1985 Stasya1985    2   02.03.2020 21:24    19

Ответы
Ivanlabur Ivanlabur  27.08.2020 22:19

program rost_ves;

var

r,v,ans:real;

begin

read(r,v);

ans:=r-100-v;

if ans=0 then

write('У Вас оптимальный вес')

else

if ans>0

then

write('Вам нужно поправится на ',ans,' кг')

else

write('Вам нужно похудеть на ',abs(ans),' кг')

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика