Написать программу, которая вводит с клавиатуры последовательность из 10 вещественных чисел, считает сумму и среднее арифметическое этих чисел. нужно составить блок-схему для этой .

maksimys maksimys    1   19.06.2019 08:50    5

Ответы
SiRuES SiRuES  02.10.2020 05:10
Pascal

var
   a,s, r : real;
   i : integer;

begin
 for i := 1 to 10 do
 begin
 readln (a);
 s := s +a;
 end;
r := s/r;
writeln ('sr=',r:3:2);
writeln ('s=',s:3:2);

end.
ПОКАЗАТЬ ОТВЕТЫ
Metalgitarist23 Metalgitarist23  02.10.2020 05:10
Var
 i:integer;  
 a,sum,s:real; 
begin    
for i:=1 to 10 do     
   begin         
    read(a);
    sum:=sum+a;      
   end;    
 write('Сумма: ',sum);   
 s:=s/10;     
write('Cреднее арифметическое: ',s);
 end.
Написать программу, которая вводит с клавиатуры последовательность из 10 вещественных чисел, считает
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика