tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу , которая
Написать программу , которая вводит с клавиатуры число от 0 до 999999(использовать переменные типа longint) и выдает на экран дисплея сумму цифр этого числа. напишите в делфи .
annyakristina
1 31.07.2019 01:40
3
Ответы
ffggshwheehejsj
28.09.2020 10:56
Var
n: longint;
i, sum: integer;
begin
Readln(n);
Sum := 0;
while n > 0 do
begin
Sum := sum + (n mod 10);
n := n div 10;
end;
Writeln(sum);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
123GEV
31.08.2019 13:40
Ураховуючи що кожний символ кодується одним байтом укажіть інформаційний обсяг такого речення: ой, яка чудова українська мова! скільки має біти...
2017МегаМозг2017
14.02.2021 14:42
Задача на Паскале. Вводится четырёхзначное натуральное число. Проверить, является ли оно палиндромом, т. е. числом, которое одинаково читается слева направо и справа...
максимка1905
14.02.2021 14:41
Ввести целое число. Если оно является отрицательным, то увеличить его в 2 раза; в противном случае вычесть из него 2. Вывести полученное число....
VPVolkov03
14.02.2021 14:38
результат s вот этого алгоритма? s- cц-т-ч-...
Diana6079
12.05.2021 11:03
Установите соответствие между названиями программ и классами программного обеспечения: Far Manager Microsoft Excel системное программное обеспечение прикладное программное...
yanssen1976
12.05.2021 11:01
Про домбру , инфарматика 4 класс...
Lena12281995
29.05.2019 03:20
Чем отличается источник информации от приемника?...
schooll13
29.05.2019 03:20
Вводятся значения двух цифр. напечатать максимальное двузначное число, которое можно сформировать из этих цифр или сообщение, что таких двузначных чисел не существует....
Wikpiklear
29.05.2019 03:20
Найдите среднее значение из трех чисел x ,y ,k. составить программу pascal и блок схему...
abdullaeff4
23.04.2020 08:11
Жұлдыз бен жеке адам өмірінің арасында байланыс бар ма , неліктен...
Популярные вопросы
4. Существуют ли треугольники со сторонами а)2; 3; 4; б) 2; 2; 4;...
3
Розв’язати квадратні рівняння: а) 2х² – 7х + 5 = 0. б) 5х2 (умножить...
1
Порівняйте потужність двигуна тролейбуса у випадках коли він рухається...
1
Кто может посоветовать пассивный зароботок, который выводит...
2
Свежие грибы содержат 90% влаги. Сушеные - 12%. Сколько килограммов...
3
У результаті реакції між олеїновою кислотою та натрій гідроксидом...
1
Вопросы по стихотворению М.Лермонтова «Морская царевна» 1. «Морская...
3
В пробирках находятся кристаллические вещества: Na2SO4, K2CO3, Na2SiO3,...
3
Озеро байкал (написать о месторасположение,известен чем,что вы можете...
3
вставь слова которые сверху в предложения даю 15 ...
2
n: longint;
i, sum: integer;
begin
Readln(n);
Sum := 0;
while n > 0 do
begin
Sum := sum + (n mod 10);
n := n div 10;
end;
Writeln(sum);
end.