Написать программу, которая вводит число. Если число двузначное, то нужно найти сумму цифр в числе. Если число трехзначное – произвести произведение цифр числа. Если число четырехзначное – найти среднее арифметическое цифр этого числа. Если число иное – вывести запись «Введите 2-х, 3-х или 4-х значное число».

salome5toriy salome5toriy    1   24.03.2020 07:47    7

Ответы
Айхан111111 Айхан111111  12.10.2020 03:22
var  x, n: integer;  n1: real; begin  Writeln('Введите число: ');  Read(x);  if (x > 9) and (x < 100) then  begin    n := (x div 10) + (x mod 10);    Writeln('Сумма цифр равна: ', n);  end;  if (x > 99) and (x < 1000) then  begin    n := (x div 100) * ((x div 10) mod 10) * (x mod 10);    Writeln('Произведение цифр равно: ', n);  end;  if (x > 999) and (x < 10000) then  begin    n := x div 1000 + (x div 100) mod 10 + (x div 10) mod 10 + x mod 10;    n1 := n / 4;    Writeln('Среднее арифметическое равно: ', n1);  end;  if x > 9999 then  begin    Writeln('Введите 2-х, 3-х или 4-х значное число');  end; end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика