Написать программу, которая в массиве случйных чисел с[1..5,1..5] меняет местами значения элементов главной и диагонали

nastamalysheva nastamalysheva    1   18.05.2019 17:40    1

Ответы
rusnaktaniusha rusnaktaniusha  30.09.2020 20:54

uses crt;

var C:array[1..5,1..5] of integer;

i,j,temp:integer;

 

begin

   randomize();

   for i:=1 to 5 do

      for j:=1 to 5 do

         C[i,j]:=random(1000);

   for i:=1 to 5 do begin

      t:=C[i,i];

      C[i,i]:=C[i,6-i];

      C[i,6-i]:=t;

   end

end.

ПОКАЗАТЬ ОТВЕТЫ
kanyakhin kanyakhin  30.09.2020 20:54

program pr;
uses crt;
Var i,j,b:integer;
C:array[1..5, 1..5] of integer;
Begin
for i:=1 to 5 do Begin
Writeln;
    for j:=1 to 5 do Begin C[i,j]:=random(100); Write(C[i,j],'|');  end;
     end;
for i:=1 to 5 do
     Begin
           b:=C[i,i];
           C[i,i]:=C[i,6-i];
           C[i,6-i]:=b;
      end;
Writeln;
      
for i:=1 to 5 do Begin
Writeln;
    for j:=1 to 5 do  Write(C[i,j],'|');
     end;
      

readln;
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика