Написать программу, которая в качестве результата дает истину, если выполняется заданное условие, или ложь, если условие не выполняется: введенное целое число является квадратом нечетного числа.(mathcad)

Емсимася Емсимася    2   04.10.2019 01:20    6

Ответы
gerasimovichninka gerasimovichninka  09.10.2020 15:49

/


Welcome to GDB Online.

GDB online is an online compiler and debugger tool for C, C++, Python, Java, PHP, Ruby, Perl,

C#, VB, Swift, Pascal, Fortran, Haskell, Objective-C, Assembly, HTML, CSS, JS, SQLite, Prolog.

Code, Compile, Run and Debug online from anywhere in world.


/

#include <stdio.h>

#include <iostream>

#include <math.h>

int main()

{

  int x=0;

 std::cin >> x;

  int tmp = round(sqrt(x));

if (sqrt(x) == tmp && tmp % 2 != 0){

   std::cout << true;

}

else{

   std::cout << false;

}

   return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика