Написать программу, которая в файле находит самого высокого человека и выводит его данные.

sijwqjhauwb sijwqjhauwb    2   27.09.2019 05:30    3

Ответы
inkakanchiyp0706d inkakanchiyp0706d  08.10.2020 22:01

//Поскольку вы не указали структуру файла и язык программирования, то подберу их сам.

//ЯП: C#

//Структура: рост/имя/вес/страна проживания

Код:

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.IO;

namespace Prog

{

class Program

{

static void Main(string[] args)

{

string location = "C://Test//Persons.txt";

try

{

int size = File.ReadLines(location).Count();

if (size > 0)

{

List<string> person = new List<string>();

string[] tallestPerson = new string[4];

int maxHeight = -1;

int height = 0;

int index = 0;

StreamReader PersonsReader = new StreamReader(location, Encoding.Default);

for (int i = 0; i < size; i++)

{

person.Add(PersonsReader.ReadLine());

height = Convert.ToInt32(person[i].Remove(person[i].IndexOf("/")));

if (height > maxHeight)

{

maxHeight = height;

index = i;

}

}

string tmp = person[index];

int paramIndex = 0;

for (int j = 0; j < tmp.Length; j++)

{

if (tmp[j] != '/')

tallestPerson[paramIndex] += tmp[j];

else

paramIndex++;

}

Console.WriteLine("Самый высокий человек: " + tallestPerson[1]);

Console.WriteLine("Рост: " + tallestPerson[0] + " см");

Console.WriteLine("Вес: " + tallestPerson[2] + " кг");

Console.WriteLine("Страна проживания: " + tallestPerson[3]);

}

else

{

Console.WriteLine("Файл пустой!");

}

}

catch (Exception)

{

Console.WriteLine("Ошибка! Файл не нейден, либо нарушена его структура!");

}

finally

{

Console.ReadKey();

}

}

}

}


Написать программу, которая в файле находит самого высокого человека и выводит его данные.
Написать программу, которая в файле находит самого высокого человека и выводит его данные.
Написать программу, которая в файле находит самого высокого человека и выводит его данные.
Написать программу, которая в файле находит самого высокого человека и выводит его данные.
Написать программу, которая в файле находит самого высокого человека и выводит его данные.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика