Написать программу , которая увеличивает число на 7, если оно меньше нуля и уменьшает на 2. если исходное число больше 0

ABILAIKhan ABILAIKhan    1   30.06.2019 14:50    4

Ответы
artemovaelena artemovaelena  02.10.2020 16:16
Var a,b,c:integer;
begin
writeln('введите число');
readln(a);
if a<0 then b:=a+7 else b:=a-2;
if a=0 then while a=0 do begin writeln('введите другое число'); end;
writeln('полученное число ', b);
end.
ПОКАЗАТЬ ОТВЕТЫ
Beheh Beheh  02.10.2020 16:16
var x : real;
begin 
 writeln ( 'Введите число : '); 
 readln (x); 
  if (x<0) then x:=x+7  
  else if (x>0) then x:=x-2; 
 writeln (' Конечное число : ',x);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика