Написать программу, которая удаляет из введенного слова любой введенный с клавиатуры символ.слово вводится в программе. pascalabc

bananchik1213 bananchik1213    3   30.07.2019 21:30    2

Ответы
ЯРОСЛАФ ЯРОСЛАФ  03.10.2020 18:03
// PascalABC.NET 3.1, сборка 1246 от 23.05.2016
begin
  var s:=ReadlnString('Введите слово:');
  var c:=ReadlnChar('Введите символ:');
  var p:=Pos(c,s);
  if p>0 then begin
    s:=s[:p]+s[p+1:];
    Writeln('Результат: ',s)
    end
  else Writeln('Такого символа в слове нет')
end.

Тестовое решение
Введите слово: информатика
Введите символ: м
Результат: инфоратика
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика