Написать программу, которая суммирует n отрицательных четных чисел из вводимых с клавиатуры чисел, при вводе n=0 выход из программы.

Rinana1298 Rinana1298    3   22.05.2019 03:30    3

Ответы
Tatarin570 Tatarin570  17.06.2020 04:25

CLS

b:

INPUT n

IF n<0 OR INT(n)<>n THEN GOTO b

IF n=0 THEN END

DIM a(n)

FOR i = 1 TO n

a:

INPUT a(n)

IF a(n) >= 0 OR INT (a(n)/2)<>(a(n)/2) THEN GOTO a

s=s+a(n)

NEXT i

PRINT s

ПОКАЗАТЬ ОТВЕТЫ
Otlichnik1703 Otlichnik1703  17.06.2020 04:25

Program ilnur17;
uses crt;
var
  n,sum,temp: integer;
begin
  write('Введите число ');
  readln(n);
  if n<>0 then
    begin
      sum:=0;
      writeln('*** alphaues is thinking... ***');
      writeln('***          OK             ***');
      while n>=1 do
        begin
          write('Введите следующее число ');
          readln(temp);
          if (temp<0) and (temp mod 2 = 0 ) then
            sum := sum + temp;
          n:=n-1
        end;
    end
  else
    writeln('Вы ввели 0 - выход из программы');
  writeln('Cуммa отрицательных четных чисел равна ',sum);
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика