Написать программу, которая суммирует 12 любых чисел (вводит пользователь или генератор случайных чисел). Использовать цикл for. Переменных не более 5 шт. и использовать цикл While. PascalABC. ​

DIMONSTERUSp DIMONSTERUSp    2   23.04.2020 21:06    2

Ответы
pirishok pirishok  09.08.2020 22:38

1) Цикл for

uses crt;

var j,count,i:integer;

begin

j:=0;

for i:=1 to 12 do

begin

 readln(count);

 j:=j+count;

end;

writeln(j);

end.

2) Цикл While

uses crt;

var j,count,i:integer;

begin

j:=0;

i:=0;

while i < 12 do

begin

 readln(count);

 j:=j+count;

 i:=i+1;

end;

writeln(j);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика