Написать программу которая сравнивает сумму четных значений с нечетными значением !

ressko123 ressko123    2   23.09.2019 11:50    2

Ответы
PrOFy100 PrOFy100  08.10.2020 12:14
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (so,se):=(0,0);
  ReadSeqIntegerWhile(t->t>0).ForEach(t->if t.IsOdd then so+=t else se+=t);
  Write('Сумма четных ',se,' ');
  if se>so then Write('>')
  else
    if se=so then Write('=')
    else Write('<');
  Writeln(' суммы нечетных ',so)
end.

Пример
3245 6774 23241 5645 967 32234 123 65 2134 0
Сумма четных 41142 > суммы нечетных 33286

Программа считывает данные, пока они являются натуральными числами.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика