Написать программу, которая сортирует записи в файле f по алфавиту по фамилиям.

annafycguvvv annafycguvvv    1   27.09.2019 05:30    6

Ответы
Тучка12 Тучка12  08.10.2020 22:01

// PascalABC.NET

// Версия 3.4 сборка 1749 (18.08.2018)


begin

var (f, out) := (ReadAllLines('in.txt'), OpenWrite('in.txt'));

f.Select((t, i)-> (t.ToWords[0], i)).Sorted.ForEach(t -> begin Writeln(out, f[t[1]]) end);

out.Close;

end.


Файл, который использовал для проверки в приложении(совпадение с реальными именами - случайность).

Считывание и запись происходит в одном файле.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика