Написать программу которая сортирует одномерный массив "методом простого выбора" в порядке возрастания на с++

Dashazavalish Dashazavalish    1   14.11.2019 23:47    8

Ответы
Спасибо666 Спасибо666  10.10.2020 13:20

#include <iostream>

#include <iomanip>

using namespace std;

int main()

{

   int n;

   cin >> n;

   int a[n];

   srand(time(0));

   for(int i=0; i<n; i++)

   {

       a[i]=-99+rand()%199;

       cout << setw(4) <<a[i];

   }

   cout << endl;

   int j=n-1;

   while(j>0)

   {

       int mx=a[0], imx=0;

       for(int i=1; i<=j; i++)

           if(a[i]>mx)

           {

               mx=a[i];

               imx=i;

           }

       a[imx]=a[j];

       a[j]=mx;

       j--;

   }    

   for(int i=0; i<n; i++)

       cout << setw(4) <<a[i];

    return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика