Написать программу, которая сможет определить, есть ли среди цифр заданного целого трёхзначного числа одинаковые. даны три переменные вещественного типа: a, b, c. если их значения по возрастанию или убыванию, то удвоить их; в противном случае заменить значение каждой переменной на противоположное. вывести новые значения переменных a, b, c.

m1kaS7ark m1kaS7ark    1   17.05.2019 17:10    3

Ответы
apollow apollow  10.06.2020 22:20

1. 

var
n, a, b, c: integer;

begin
readln(n);
a := n div 100;
b := n div 10 mod 10;
c := n mod 10;
if (a = b) or (b = c) or (a = c) then writeln('YES')
else writeln('NO');
end.

 

2.

var
a, b, c: real;

begin
readln(a, b, c);
if ((a < b) and (b < c)) or ((a > b) and (b > c)) then begin a := a * 2;b := b * 2;c := c * 2; end
else begin a := -a;b := -b;c := -c; end;
writeln(a,' ', b,' ', c);
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика