Написать программу, которая считывает две строки, введённых пользователем. После этого программа должна вывести на экран, какая строка длиннее и на сколько символов.(Python)(В коде должно быть ветвление if … elif … else
Вычисление разницы в длине строк должно выполняться в функции, которая принимает две строки и возвращает целое число.)

sayvik1 sayvik1    2   27.03.2020 10:28    1

Ответы
raisa3yusif raisa3yusif  12.10.2020 06:42

def get_string_length_diff(string1, string2):

   return len(string1)-len(string2)

fstring = input()

sstring = input()

strings_diff = get_string_length_diff(fstring, sstring)

print(f'первая строка длиннее на {abs(strings_diff)} символов' if (strings_diff > 0) else f'вторая строка длиннее на {abs(strings_diff)} символов')

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика