tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу, которая
Написать программу, которая считывает число с экрана и выводит сумму цифр этого числа. паскаль
viktrozumovskaoyqqjq
3 23.07.2019 02:30
2
Ответы
Farzalievik
23.09.2020 20:53
Var
n, s: integer;
begin
write('Число: ');
readln(n);
s := 0;
while n > 0 do
begin
s := s + n mod 10;
n := n div 10
end;
writeln('Сумма цифр = ', s);
end.
Тестовое решение:
Число: 12345
Сумма цифр = 15
ПОКАЗАТЬ ОТВЕТЫ
дианка204
23.09.2020 20:53
На Java
http://pastebin.com/SbfSZLFK
ввод - 1234567890123456
вывод - 66
var n, sum: integer;
begin
readln(n);
sum := 0;
while n > 0 do begin
sum := sum + n mod 10;
n := n div 10
end;
writeln(sum);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
aidafarhadova
14.05.2020 09:33
У исполнителя Бета две команды, которым присвоены номера: 1) прибавь 2; 2) умножь на b (b — неизвестное натуральное число; b ≥ 2). Выполняя первую из них, Бета увеличивает число...
Vtscrntfigduufs
14.05.2020 09:34
Напишите программу на Паскале: С клавиатуры вводятся два произвольных числа. Компьютер выдает на экран сообщение о том, какое из чисел больше, либо они равны. Используйте неполную...
Ангелина8281
14.05.2020 09:34
Во Выберите верные утверждения. Для безопасной работы в сети Интернет рекомендуется: Укажите один или несколько правильных вариантов ответа отправлять персональную информацию...
Zlatasolnce
19.10.2020 12:48
Соотнесите десятичные числа в двоичную эквивалентами 4 112 5 1101 2 1172D 8 127...
эмриханастчсия
19.10.2020 12:53
Сообщество роботов живет по следующим законам: один раз в год они объединяются в полностью укомплектованные группы по 3 или 5 роботов (причем число групп из 3 роботов — максимально...
Vika47696
19.10.2020 12:26
Имеется схематическое представление получения двоичных кодов. Запишите все возможные значения двоичного кода, которые можно получить из данной схемы...
kryukova20023
19.10.2020 12:49
1) запишите в развёрнутой форме числа (фото закрепила) 2)как от свернутой формы записи десятичного числа перейти к его развернутой форме? ...
leafpool1
19.10.2020 12:49
Сколько всего существует штрих-кодов из 6 штрихов, некоторые из которых закрашены,а некоторые нет, но при этом крайние штрихи закрашенны и в штрих кодах нет никаких трёх подряд...
врондао
19.10.2020 12:48
Нужно заполнить пространства и записать решение...
g3force
11.03.2019 14:10
Объясните как это решать ) в таблице запросы к поисковому серверу. расположите обозначения запросов в порядке возрастания количества страниц, которые найдет поисковый сервер...
Популярные вопросы
Скласти діалог - домовлення або розпитування (телефонної розмови) з використанням...
1
ЗАДАНИЕ ВРЕМЯ НА ВРЕМЯ НА ВЫПОЛНЕНИЕ : 00:00 No3 ТЕКСТ ЗАДАНИЯ Берілген тұрақты...
2
обчисліть масу амоній хлориду , добутого з амоніаку масою 30 г і хлороводню...
2
решите уравнение, у меня урок по-братски...
3
2 тапсырма берілген эпизодтармен кейіпкер бейнесін сәйкесиірініз...
3
Составьте 2 СПП на тему «Туризм», укажите тип придаточного...
2
Скорость движения улитки равна 5 дм мин сколько метров проползет улитка За...
1
На яку татарську фортець Іван Сірко здійснив напад після битви під Конотопом?...
2
Почему сопротивление проводника равно, если напряжение на его концах составляет...
2
егінің бастары өленіңдегі дәнге толы және дәні жоқ егіннің бастарын сипаттайтын...
1
n, s: integer;
begin
write('Число: ');
readln(n);
s := 0;
while n > 0 do
begin
s := s + n mod 10;
n := n div 10
end;
writeln('Сумма цифр = ', s);
end.
Тестовое решение:
Число: 12345
Сумма цифр = 15
http://pastebin.com/SbfSZLFK
ввод - 1234567890123456
вывод - 66
var n, sum: integer;
begin
readln(n);
sum := 0;
while n > 0 do begin
sum := sum + n mod 10;
n := n div 10
end;
writeln(sum);
end.