Написать программу, которая считает значение y при любом целом значении x (паскаль) y = 1/(x+1)^2

Mooz Mooz    1   12.11.2019 23:50    0

Ответы
Грихыч2002 Грихыч2002  10.10.2020 12:55

begin

 Println(1/Sqr(ReadInteger+1))

end.

Примеры:

7

0.015625

-4

0.111111111111111

0

1

-1

Infinity (это означает бесконечность)

ПОКАЗАТЬ ОТВЕТЫ
wexly wexly  10.10.2020 12:55

program smth;

var x, y : real;

Begin

writeln ('Введите значение x');

readln (x);

y := 1 / sqr(x+1);

if (sqr(x+1) = 0) then

writeln ('Знаменатель = 0')

else

writeln ('Значение y = ', y);

end.

----------------------------------

Или

----------------------------------

program smth;

var x, y : real;

Begin

writeln ('Введите значение x');

readln (x);

if (x <> -1) then

Begin

y := 1 / sqr(x+1);

writeln ('Значение y = ', y)

end

else

writeln ('Знаменатель = 0');

end.


Написать программу, которая считает значение y при любом целом значении x (паскаль) y = 1/(x+1)^2
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика