Написать программу которая считает количество цифр в числе и их сумму. паскаль. число вводится с клавиатуры

wwe555 wwe555    1   11.08.2019 02:30    1

Ответы
Саляриум Саляриум  04.10.2020 10:26
Для натуральных чисел:
var a,k,s:integer;
begin
write('a = ');
readln(a);
k:=0; s:=0;
while a>0 do
 begin
 k:=k+1;
 s:=s+a mod 10;
 a:=a div 10;
 end;
writeln('k = ',k,', s = ',s);
end.

Пример:
a = 352186
k = 6, s = 25
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика