Написать программу которая решает уравнение ax^2+bx+c=0 . если d< 0 то решений нет , если d=0 то 1 корень. еси d > 0 - 2 корня

sonyabush12345 sonyabush12345    1   17.09.2019 01:00    4

Ответы
sofiyaserysheva sofiyaserysheva  07.10.2020 20:51
//PascalABC.NET
//Версия 3.3, сборка 1611
begin
var (a,b,c):=ReadReal3('введите a, b и c через пробел');
var D:=b*b-4*a*c;
if D>0 then write('два различных корня: x1=',(-b+sqrt(D))/(2*a),'; x2=',(-b-sqrt(D))/(2*a)) else if D=0 then
write('два совпадающих корня: x1=x2=',-b/(2*a)) else
write('нет действительных корней');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика