Написать программу которая расчитывает количество прожитых дней по введеному значению полных лет человека если что мне 13

Польди Польди    1   19.05.2019 17:30    3

Ответы
Котенок050402 Котенок050402  30.09.2020 23:51

На каком языке программу писать, следовало бы уточнить.
Вот на С# без учета високосного года:

 

#include<stdio.h>
#include<stdlib.h>

int main()
{
int age, res;

printf( "Введите ваш возраст:\n" );
scanf( "%i", &age );

res = age * 365;

printf( "Вами прожито: %i дней\n", res );

system( "pause" );
return 0;
}

Если нужно учитывать високосный год, то добавляется соответственное условие, делящее возраст на 4 и потом плюсуется количество дней из полученного (целого значения)

ПОКАЗАТЬ ОТВЕТЫ
привет980 привет980  30.09.2020 23:51

Язык Pascal. С учетом високосных годов.

var

  age, days: integer;

 

begin

  writeln('Введите возраст человека в годах');

  readln(age);

  days:= age * 365 + (age div 4);

  writeln('Количество прожитых дней: ', days);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика