Написать программу, которая проверяет следующий факт: все цифры данного четырехзначного числа n различны

555555Эвелина 555555Эвелина    2   04.10.2019 00:00    6

Ответы
Vivy12 Vivy12  09.10.2020 15:42

var n,a,b,c,d:integer;

begin

readln(n);

a:=n mod 10;

b:=(n div 10) mod 10;

c:=(n div 100) mod 10;

d:=n div 1000;

if((a-b<>0)or(c-d<>0)or(a-d<>0)) then writeln('Цифры введённого четырёхзначного числа различны') else

writeln('Цифры введённого четырёхзначного числа одинаковы');

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика