Написать программу, которая проверяет, образуют ли элементы введенного с клавиатуры массива неубывающую последовательность отрицательных чисел.с++.

mlevosin mlevosin    3   01.10.2019 14:40    4

Ответы
vladrifeyt1 vladrifeyt1  09.10.2020 07:56
#include <iostream>

int main()
{
int length;
bool flag=true;
std::cout<<"Введите длину массива: ";
std::cin>>length;
int *array=new int[length];
for (int i=0;i<length;i++)
{
std::cin>>array[i];
if (i>0)
if (array[i-1]>array[i])
flag=false;
if (array[i]>=0)
flag=false;
}
std::cout<<(flag?"true":"false");
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика