Написать программу которая проверяет находится ли в массиве введенное с клавиатуры число. массив должен вводиться случайным образом(pascal)

NeznaykaVshkole NeznaykaVshkole    1   22.05.2019 11:30    5

Ответы
оооооченьТупой оооооченьТупой  17.06.2020 20:23

В массиве n элементов.
Случайным образом вводятся целые числа от 0 до 999.
x - ведённое с клавиатуры число.
i - цикловая переменная.

var
a : array [1..100] of integer;
x, i, n : integer;
begin
readln (n);
for i := 1 to n do
a [ i ] := random (1000);
readln (x);
for i := 1 to n do
if a [ i ] := x then
writeln ('введённое с клавиатуры число находится в массиве');
end.

Если количество элементов в массиве известно изначально, например 25,  тогда строку " readln (n); " убираете, а строки
" for i := 1 to n do "
заменяете на
" for i := 1 to 25 do "

Минус данной программы: если введённое с клавиатуры число не находится в массиве, то программа ничего не выводит.

ПОКАЗАТЬ ОТВЕТЫ
bon332 bon332  17.06.2020 20:23

var

  a:array [1..100] of integer;

  i,n,k:integer;

  f:boolean;

begin

  write ('Razmer massiva (N<100): ');readln(n);

  for i:=1 to n do begin

    a[i]:=random(36)-10;

    write (a[i],' ');

  end;

  writeln; 

  write ('Number: ');readln(k);

  f:=false;

  for i:=1 to n do

    if a[i]=k then f:=true; 

  writeln (f);

  readln;

end.

Выводит FALSE, если в масиве нет числа,иначе выводит TRUE.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика