Написать программу, которая позволяет ввести 12 значений. далее программа выводит на экран два числа. в одно число нужно записать сумму чисел меньше 100, а в другое сумму чисел меньше 100. то есть при вводе программа должна определить какие значения ты вводишь и разбивает значения на 2 группы, меньше 100 и больше 100, а далее суммирует числа в каждой группе и выводит ответ.

alex2071 alex2071    2   08.09.2019 21:02    3

Ответы
1828384858 1828384858  07.10.2020 01:43

program raf105;

var

 num,sum1,sum2: integer;

begin

 writeln('Вводите 12 чисел по очереди');

 for var i:=1 to 12 do

 begin

   readln(num);

   if num < 100 then sum1:= sum1 + num;

   if num > 100 then sum2:= sum2 + num;

 end;

 writeln('Сумма чисел меньше 100: ',sum1);

 writeln('Сумма чисел больше 100: ',sum2);

end.

PascalABC
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика