Написать программу, которая позволяет просматривать текстовые файлы (выводит на экран содержимое файла) , например, файлы исходных программ turbo pascal. имя просматриваемого файла должно вводится во время работы программы. рекомендуемый вид экрана ниже. просмотр текстового файла. введите полное имя файла и нажмите . -> d: \tp\pas\numb.pas

Zmei0907 Zmei0907    3   27.05.2019 21:10    7

Ответы
elenshv elenshv  25.06.2020 01:25
Var f1:text;
st:string;
begin
write ('введите имя файла ');
readln(f1);
reset (f1); { открыть файл для чтения }
while not eof (f1) do { пока не конец файла  f1}
begin
readln (f1, st);    {читаем строку из файла f1 }
writeln(st);         { выводим на экран }
end;
close (f1); { закрыть файл  для чтения}
end .
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика