Написать программу, которая после ввода пользователем трёхзначного числа вычисляет сумму его цифр.

vasakaktakovlwla vasakaktakovlwla    2   09.03.2019 05:40    4

Ответы
SlavaRPSS SlavaRPSS  24.05.2020 09:46

var a,a1,a2,a3 : integer;  

begin

  readln(a);

  a1:=a div 100;

  a2:=(a mod 100) div 10;

  a3:=(a mod 100) mod 10;

  writeln(a1+a2+a3);

end.

 а - само число, а1-число сотен, а2-число десятков, а3-число единиц

 

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика