Написать программу, которая получает на вход число произвольной длины меньше, чем 9 знаков и показывает, какие в нем повторяющиеся цифры быстрее! 11! мог не правильно понять вопрос, напишите хоть что-нибудь похожее , нужно

Лика1508 Лика1508    2   22.08.2019 03:40    2

Ответы
Tasher3tapora Tasher3tapora  05.10.2020 11:42
var i,n,k: integer;
    a: array[0..9] of integer;
begin
  write('число: ');  readln(n);
  for i:=0 to 9 do a[i]:=0;
  while n>0 do
  begin
    k:=n mod 10;
    a[k]:=a[k]+1;     
    n:=n div 10;
  end;  
  for i:=0 to 9 do 
  if a[i]>1 then writeln('повторяющаяся цифра: ',i);
end.

число: 1022315
повторяющаяся цифра: 1
повторяющаяся цифра: 2
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика