Написать программу, которая показывает пользователю на экран три страны и предлагает выбрать одну. после того, как пользователь выберет страну, программа показывает три города (для какой-то страны может показать правильно, для какой-то - нет) и спрашивает пользователя, относятся ли эти города к выбранной им стране. после ответа пользователя, программа сообщает ему, правильно он ответил, или нет на с++

annavelikks03 annavelikks03    3   13.09.2019 07:10    3

Ответы
Denis12o9 Denis12o9  07.10.2020 11:19
#include <iostream>
using namespace std;

int main() {
 setlocale(LC_ALL, "Russian");
 int n,k;
 string s[3][3]=
 {{"1 - Перу","2 - Тайланд","3 - Венгрия"},
 {"Лима, Арекипа, Куско", "Паттайя, Чиангмай, Сиемреап", "Сентендре, Секешфехервар, Веспрем"},
 {"Все эти замечательные города находятся в Перу",
 "Паттайя и Чиангмай находятся в Тайланде, но Сиемреап - это Камбоджа",
 "Все перечисленные города с непростыми названиями находятся в Венгрии"}};
 cout << "Выбери страну по номеру: " << s[0][0] << " " << s[0][1] << " " << s[0][2] << "\n";
 cin >> n;
 cout << "Относятся ли перечисленные ниже города к выбранной стране?\n";
 cout << s[1][n-1] << "\n";
 cout << "Да-1, Нет-0 ";
 cin >> k;
 if ((n==1)&&(k==1)||(n==2)&&(k==0)||(n==3)&&(k==1)) cout << "Вы правы! \n";
 else cout << "Вы ошиблись.\n";
 cout << s[2][n-1];
 return 0;
}

Написать программу, которая показывает пользователю на экран три страны и предлагает выбрать одну. п
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика