Написать программу, которая подсчитывает количество положительных и отрицательных элементов файла целых чисел des.dat. pascal abc

tayteldiyev2005 tayteldiyev2005    2   26.09.2019 22:40    1

Ответы
pashamironov20 pashamironov20  08.10.2020 21:17
Var
  f:file of integer;
  i,n,kp,ko:integer;
begin
  { создать файл }
  randomize;
  assign(f,'des.dat');
  rewrite(f);
  for i:=1 to 20 do
  begin
    n:=random(101)-50;
    Write(n,' ');
    Write(f,n)
  end;
  close(f);
  Writeln;
  { работа с файлом }
  ko:=0;
  kp:=0;
  reset(f);
  while not eof(f) do
  begin
    Read(f,n);
    if n>0 then Inc(kp)
    else if n<0 then Inc(ko)
  end;
  close(f);
  Writeln('Положительных ',kp,', отрицательных ',ko)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика