Написать программу, которая подсчитывает количество четных индексов положительных элементов введенного с клавиатуры массива целых чисел.

максим885б максим885б    3   22.05.2019 11:20    3

Ответы
ivolapseb ivolapseb  17.06.2020 20:23

var

  a:array [1..100] of integer;

  i,n,k:integer;

begin

  write ('Razmer massiva: ');readln(n);

  k:=0; 

  for i:=1 to n do begin

    write ('A[',i,'] = ');readln(a[i]);

    if (a[i]>0) and (i mod 2 = 0) then k:=k+1;

  end;

  writeln ('Kol-vo: ',k);

  readln;

end.

ПОКАЗАТЬ ОТВЕТЫ
sveta4841 sveta4841  17.06.2020 20:23

a - массив из n элементов
k - количество четных индексов положительных элементов
i - цикловая переменная, также индекс элемента массива
Язык программирования: Паскаль

var
a : array [1..100] of integer;
n, k, i : integer;
begin
k := 0;
readln (n);
for i:=1 to n do
begin
readln (a [ i ]);
if (i mod 2 = 0) and (a [ i ] > 0) then
k := k + 1;
end;
writeln (k);
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика