Написать программу которая подает на вход 10 натуральных чисел . сами числа не превышают 100. если среди них есть чисел кратные 4, то вывести их сумму на экран​

Shafner777 Shafner777    3   15.05.2019 17:58    6

Ответы
БезумныйКами666 БезумныйКами666  10.06.2020 08:48

с++

#include <iostream>

#include <ctime>

using namespace std;

int main() {

srand(time(NULL));

int arr[10],sum=0;

for (int i = 0; i < 10; i++) //заполнение массива  

{

 arr[i] = rand() % 100;

}

for (int i = 0; i < 10; i++) //вывод массива

{

 cout << arr[i] << "\t";

}

cout << endl;

for (int i = 0; i < 10; i++) //узнаем кратность чисел

{

 if (arr[i] % 4 == 0) {

  sum = sum + arr[i];

 }

}

cout << sum << endl;

 system("pause");

 return 0;

}

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика