Написать программу которая по вводу с клавиатуры трех действительных чисел выводит на экран сообщение о том могут ли они являться сторонами треугольника

ANT1XA1P ANT1XA1P    2   02.06.2019 18:40    1

Ответы
бес12 бес12  03.07.2020 12:16
Нужно воспользоваться свойством треугольников:
Любая сторона треугольника меньше суммы двух других сторон и больше их разности .
Pascal
Var a,b,c:integer;
begin
readln(a,b,c);
if (a<b+c) and (a>b-c) and (b<a+c) and (b>a-c) and (c<b+a) and (c>b-a) then
writeln('Yes')
else
writeln('No');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика