Написать программу, которая по трем заданным углам треугольника определяет и выдаёт на экран вид этого треугольника на pascal

12365s 12365s    2   28.08.2019 11:20    1

Ответы
sahakohela sahakohela  06.10.2020 00:27
Var a,b,c: integer;
begin
write('a= ');
readln(a);
write('b= ');
readln(b);
write('c= ');
readln(c);
if a + b + c <> 180 then
 writeln('Треугольник не существует') else
if (a = 180) or (b = 180) or (c = 180) then
 writeln('Треугольник вырожденный') else
if (a = 90) or (b = 90) or (c = 90) then
 writeln('Треугольник прямоугольный') else
if (a > 90) or (b > 90) or (c > 90) then
 writeln('Треугольник тупоугольный')
else writeln('Треугольник остроугольный');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика