Написать программу которая по номеру дня недели выдаст название дня и количество уроков в вашем классе .в паскале .ps уроков у нас 6 каждый день .кроме среды. в среду 7 уроков

mihaikl mihaikl    2   30.06.2019 22:10    6

Ответы
MIO05 MIO05  24.07.2020 11:57
Пронумеруем дни недели числами от 0 до 6 (0-Вс, 1-Пн, .. 6-Сб).

var
  dow:0..6;
begin
  Write('Введите номер дня недели (0-Вс, 6-сб): ');
  Read(dow);
  case dow of
  0:Writeln('Воскресенье, выходной');
  1:Writeln('Понедельник, 6 уроков');
  2:Writeln('Вторник, 6 уроков');
  3:Writeln('Среда, 7 уроков');
  4:Writeln('Четверг, 6 уроков');
  5:Writeln('Пятница, 6 уроков');
  6:Writeln('Суббота, 6 уроков');
  else Writeln('Введено неверное значение')
  end
end.

Тестовое решение:
Введите номер дня недели (0-Вс, 6-сб): 5
Пятница, 6 уроков
ПОКАЗАТЬ ОТВЕТЫ
Dudos213 Dudos213  24.07.2020 11:57
Program al;
Var
  x: integer;
BEGIN
Repeat
Write('VVedite cislo ot 1 äî 7: ');
 Readln(x);
until x in [1..7];
Case x of
  1: Writeln('Ponidelnik-6urokov');
  2: writeln('Vtornik-6erokov');
  3: writeln('Sreda-7urokov');
  4: writeln('Cetverg-6urokov');
  5: writeln('Piatnita-6urokov');
  6: writeln('Subbota-6urokov');
  7: writeln('Voskresenie-vihadnoy');
end;
Readln
END.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика