Написать программу, которая определяет в одномерном массиве, заполненном случайным образом, количество элементов, значения которых меньше числа, введенного с клавиатуры. если есть, то вывести эти элементы

ГенийАнастасия ГенийАнастасия    1   22.08.2019 20:30    4

Ответы
Айгуль11111катон Айгуль11111катон  05.10.2020 13:21
Program n1;
const n=17;
var a: array[1..n] of integer;
i,c,k: integer;
begin
randomize;
write('введите число: ');
readln(c);
writeln('массив: ');
for i:=1 to n do
begin
a[i]:=random(50);
write(a[i],' ');
end;
writeln;
writeln('эл. которые меньше ',c);
for i:=1 to n do if a[i]<c then
begin
k:=k+1;
write(a[i],' ');
end;
writeln;
writeln('количество: ',k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика