Написать программу, которая определяет сколько единиц в числе, которое ввёл пользователь. например, в числе 197313 – две единицы. ( циклом)

ArianaLi ArianaLi    1   25.01.2020 11:01    540

Ответы
ulialepsha ulialepsha  11.10.2020 03:05

program p1;

var n,k1:integer;

begin

k1:=0;

write ('Введите число ');

readln (n);

write ('Количество единиц в числе ',n,' равно ');

repeat

if n mod 10 = 1 then k1:=k1+1;

n:=n div 10;

until n=0;

write(k1);

end.

ПОКАЗАТЬ ОТВЕТЫ
sonerraz sonerraz  11.10.2020 03:05

На python:

Объяснение:

a = input("Введите число: ")

b = 0

for i in list(a):

   if i == '1':

       b += 1

print("'1' - ", b)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика