Написать программу которая определяет нуль и считает его количество из ряда введенных чисел. и объяснить каждую

SOLA228 SOLA228    2   10.06.2019 20:10    4

Ответы
DashaTaylor11 DashaTaylor11  09.07.2020 01:42
Var s:string;   
i,sum:integer; // Объявление переменных
begin             // Начинаем программу
writeln('Vvedite chislo'); // Вывод текста
readln(s); // Ввод текста
sum:=0; // Присваиваем переменной sum значение 0 чтобы при вводе текста отличного от 0, программа выводила правильный результат то есть 0.
for i:=1 to length(s) do if s[i]='0' then sum:=sum+1; // Запускаем счетчик с 1 до length(s) что значит эта команда, она считает сколько в тексте символов. И проверяем с 1 символа до length(s) совпадает ли символ со значением 0, если совпадает то прибавляем 1.
writeln(sum); // Вывод суммы
end. // Конец программы
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика