Написать программу, которая определяет количество положительных элементов в массиве х[1..10], введенном с клавиатуры

Evagevko Evagevko    1   30.08.2019 20:20    1

Ответы
aksiniaplotniko aksiniaplotniko  06.10.2020 05:42
Uses Crt;
Const
   N = 10;
Var
   X:array[1..N] of integer;
   i,k:integer;
Begin
ClrScr;
Write('Введите массив целых чисел X(',N,'): ');
For i:= 1 to N do
    Begin
    Read(X[i]);
    if X[i] > 0 then k:=k+1
    End;
WriteLn('Количество положительных элементов X(',N,'): ',k);
ReadLn
End.

Пример работы программы:

Введите массив целых чисел X(10): 1 2 3 -4 -5 -6 7 8 9 0
Количество положительных элементов X(10): 6
ПОКАЗАТЬ ОТВЕТЫ
хики2 хики2  06.10.2020 05:42
// PascalABC.NET 3.2, сборка 1427 от 24.04.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var x:=ReadArrInteger(10);
  Writeln('Кол-во положительных равно ',x.Where(t->t>0).Count)
end.

Пример
-15 18 -6 11 0 5 -3 -14 20 19
Кол-во положительных равно 5
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика