Написать программу, которая определяет какой элемент максимальный или минимальный первым встречается в одномерном массиве из 10 чисел(паскаль)

JafarSafarov JafarSafarov    1   31.05.2019 16:20    4

Ответы
AnnaKaramelka6684 AnnaKaramelka6684  02.07.2020 01:24
Consr n=10;
var a,i,max,min,k,p:integer;
m:array [1..n] of integer;
begin
for i:=1 to n do
begin
a:=random(21)-10;
m[i]:=a;
write (m[i],' ');
end;
max:=m[1];
min:=m[1];
k:=1;
p:=1;
for i:=1 to n do
begin
if m[i]>max then
  begin
  max:=m[i];
  p:=i;
  end;
if m[i]<min then
  begin
  min:=m[i];
  k:=i;
  end;
end;
if p>k then writeln ('минимальный раньше')
else writeln ('максимальный раньше');
end.
ПОКАЗАТЬ ОТВЕТЫ
Vikatop10 Vikatop10  02.07.2020 01:24
Во вложении
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика