Написать программу которая определит сумму всех цифр пятизначного числа x(вводятся с клавиатуры) и вывести на экран сообщение.и определить заканчивается эта сумма на 3,является ли эта сумма четным

nosok666 nosok666    2   23.08.2019 18:40    3

Ответы
DianaSi12 DianaSi12  05.10.2020 15:06
//PascalABC.Net 3.2
begin
var x:=readinteger ('Введите x: ');
var sum:=0;
repeat
sum+=x mod 10;
x:=x div 10;
until x=0;
writeln ('Сумма цифр: ', sum);
writeln ('Сумма заканчивается на 3: ', (sum mod 10)=3);
writeln ('Сумма четная - ', sum.Iseven);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика