Написать программу которая найдет сумму цифр введенного с клавиатуры трехзначного натурального числа n

krasnikovanastoyhpaj krasnikovanastoyhpaj    2   14.03.2019 07:40    3

Ответы
PomogiteSAS PomogiteSAS  25.05.2020 06:45

program Sum;

var

    a,b,c,s: integer;

begin

WriteLn('Введите числа а,в,с');

ReadLn(a,b,c);

s:=a+b+c;

WriteLn('Сумма чисел равна',s);

end.

ПОКАЗАТЬ ОТВЕТЫ
мугамбе мугамбе  25.05.2020 06:45

program Sum;

var

    a,s: integer;

begin

WriteLn('Введите трехзначное число а');

ReadLn(a);

While (a div 10>0)

begin

s:=s+ (a mod 10 );

a:=a div 10;

end

s:=s+a;

WriteLn('Сумма чисел равна',s);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика