Написать программу,которая находит все четырехзначные числа abcd,для которых выполняются условия 1)a,b,c,d-разные цифры 2)a*b-c*d=a+b+c+d

danilasavap0a3nj danilasavap0a3nj    3   03.06.2019 16:10    2

Ответы
aidana200257 aidana200257  03.07.2020 22:34
Program fofgogjoj;
var 
a,b,c,d:integer;
begin
for c:=0 to 7 do 
begin
a:=c+2; 
d:=9-c;
for b:=0 to 9 do 
begin
if (b<>c)and(b<>a)and(b<>d) then
Writeln(a,b,c,d);
Writeln;
end;
end;
readln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика