Написать программу, которая находит сумму элементов с n1 до n2 одномерного массива, заполненного случайным образом. номера элементов n1, n2 вводятся с клавиатуры с проверкой корректности ввода. необходимо вывести исходный одномерный массив, а затем сумму элементов введенного диапазона.

danikru56 danikru56    1   23.08.2019 09:50    21

Ответы
ясин9595 ясин9595  08.09.2020 22:45
// PascalABC.NET 3.2, сборка 1385 от 14.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Число элементов в массиве:');
  var a:=ArrRandom(n,1,99);
  Write('Исходный массив: '); a.Println;
  var n1,n2:integer;
  Write('Границы номеров элементов для суммы: '); Read(n1,n2);
  if n1>n2 then Swap(n1,n2);
  if (n1<1) or (n2>n) then Writeln('Границы выходят за пределы массива')
  else Writeln('S=',a[n1-1:n2].Sum)
end.

Пример
Число элементов в массиве: 15
Исходный массив: 89 82 45 28 88 68 34 19 35 26 67 43 71 96 66
Границы номеров элементов для суммы: 4 9
S=272
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика