Написать программу которая находит сумму цифр числа паскаль ( ну или хотя бы идейку подкиньте)

aksnastena aksnastena    2   12.06.2019 23:40    4

Ответы
Кириджа114 Кириджа114  10.07.2020 09:30
Program summa;
var a,x:integer; 
i,s:integer;
begin 
writeln('введите целое число');
 readln( a );
 x:=a; 
s:=0; 
while ( x<>0 ) do  begin   s := s + (x mod 10); 
  x := x div 10; 
end;
writeln( 'Сумма цифр числа ',a,' = ', s );
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика