Написать программу, которая находит площадь треугольника по формуле. С использованием делегатов

Deyzer777 Deyzer777    3   09.06.2020 12:54    7

Ответы
лилия253 лилия253  30.08.2020 11:55

using System;

namespace kp9p_pr_10_zad_6

{

   class Program

   {

       delegate void Square(double a1, double b1, double alfa1);

       static void Main(string[] args)

       {

           double a, b; // переменные для сторон a и b  

           double alpha; // переменная для угла альфа  

           Console.WriteLine("Введите значения треугольника:\n ");

           Console.Write("a: ");

           a = double.Parse(Console.ReadLine());   // ввод стороны a  

           Console.Write("b: ");

           b = double.Parse(Console.ReadLine()); // ввод стороны b  

           Console.Write("Угол альфа: ");

           alpha = double.Parse(Console.ReadLine()); // ввод угла альфа  

           sq(a, b, alpha);  

           static void sq(double a1, double b1, double alpha1) // функция sq расчета и вывода площади  

           {

               Console.WriteLine("\nПлощадь: {0}", (a1 * b1 * Math.Sin(alpha1)) / 2); // вывод и расчет площади  

           }

       }

   }

}  

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика