Написать программу, которая находит максимальное нечетное число среди чисел ,записанных в файле, и выводит результат в другой файл. подскажите как найти это число хотя бы

bokkvika2908 bokkvika2908    1   24.08.2019 07:00    4

Ответы
alisher0901 alisher0901  20.08.2020 14:52
Program n1;
type z = array of integer;
var a: z;
i,n,max: integer;
f: text;
begin
assign(f,'input.txt');
reset(f);
n:=0;
while not eof(f) do
begin
n:=n+1;
setlength(a,n);
read(f,a[n-1]);
end;
close(f);
max:=a[0];
for i:= 1 to n-1 do
if (a[i]>max) and(a[i] mod 2<>0) then max:=a[i];
assign(f,'output.txt');
rewrite(f);
write(f,max);
close(f);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика